Author Topic: Am I going nuts ?  (Read 5192 times)

Offline luke

  • Sr. Member
  • ****
  • Posts: 191
  • Member
    • View Profile
  • Do you own a Track Product?: Tvan
  • Location: Brisbane
Re: Am I going nuts ?
« Reply #15 on: February 12, 2020, 08:10:00 PM »
https://www.mrlugnut.com.au/lugnuts.html
Part no: 5077-1/2

The new nuts worked like a charm. 

Although I measured everything before ordering, I was still a little worried about the length of the shank so tested them without the wheels (straight back to the hub) and no issues.

Another reason I was originally wanting to change the studs was because the old nuts were a different size to the Prado, but the new ones are also a 21mm socket. (Same as Prado)

The wheels are 'lug centric', however so were the steel wheel's as fitted by track originally, so I guess we'll see how they go.  Other than that, the hub caps don't fit, but I can live with that in the short term . . .

Now I just need to sell the old wheels  :D
Tvan Canning Mark IV (Dec 2015)
Soon to be Prado 150

Offline Alien

  • Sr. Member
  • ****
  • Posts: 215
  • Member
    • View Profile
  • Do you own a Track Product?: Tvan
  • Location: Bacchus Marsh
Re: Am I going nuts ?
« Reply #16 on: February 13, 2020, 06:12:42 AM »
Good to see you’ve sorted the nut issues.
I’d suggest looking into making the wheels hub centric, in my case I had slip rings made up.
https://www.machinedesign.com/fastening-joining/article/21832042/whats-the-difference-between-lugcentric-and-hubcentric-wheels
Kyle & Coral.
Propulsion unit-  Land Rover Defender.
Accommodation- '06 Canning Tvan.